Antiguo BlogLinuxMultimediaVideo

mencoder en Debian (debian-multimedia.org)

Siempre me ha extrañado que mencoder no viniera como paquete en la distribución Debian GNU/Linux, de hecho recuerdo que cuando empecé a utilizar Debian ni siquiera mplayer venía incluido como paquete.

El caso es que quiero recordar que hace tiempo leí que era algún tema de licencias[1], pero a día de hoy parece estar solucionado, e incluso en la distribución Debian ya viene incluido dentro de los repositorios main el paquete mplayer, con el inconveniente de que no trae la aplicación mencoder.

Según tengo entendido, mencoder es una aplicación de mplayer, pero por extrañas circunstancias la aplicación no viene dentro del paquete de mplayer. De hecho, consultando los repositorios de Ubuntu veo que hay un paquete independiente para ambas aplicaciones.

Para instalar mencoder en nuestra distribución Debian, supongo que una solución pasa por descargar las fuentes de mplayer (donde me imagino viene incluida mencoder), compilarlas e instalarlas… aunque para esto me imagino que primero habría que desinstalar el paquete mplayer en caso de tenerlo instalado.

La otra solución (que es la que he probado), es agregar el repositorio de debian-multimedia.org a nuestro sources.list e instalar los paquetes desde dicho repositorio.

En mi caso he seguido el siguiente procedimiento:

# echo “deb http://www.debian-multimedia.org testing main” >> /etc/apt/sources.list

# aptitude update

# aptitude install debian-multimedia-keyring

# aptitude install mencoder

Referencias:

  1. [esdebian.org]~$ Paquete de mplayer
  2. [es.wikipedia.org]~$ MEncoder
  3. [mplayerhq.hu]~$ Capítulo 8. Codificando con MEncoder
  4. [mplayerhq.hu]~$ man mencoder
  • Gracias, me ha sido muy útil la info!

  • Mauro

    Muchisimas gracias por la info!, me vino de 10.. instalé DeVeDe, me pedía MPlayer y MEncoder, pero al parecer estaban mal instalados o no estaban 🙂 Solucionado

  • Baku

    Muchas gracias. No tenía manera de instalarlo hasta que dí con tus indicaciones. Muchas gracias de nuevo y saludos.

  • antis

    Muchas gracias por tu ayuda, tambien yo solucione el problema con mplayer y mencoder y ahora hasta me aparece devede justo lo que queria de nuevo muchas gracias

  • Jairo

    auxilio! no puedo instalar mencoder me aparece esto
    No se satisfacen las dependencias de los siguientes paquetes:
    mencoder: Depende: libdirac-decoder0 que es un paquete virtual.
    Depende: libdirac-encoder0 que es un paquete virtual.
    Depende: libfaad2 que es un paquete virtual.
    Depende: libfontconfig1 (>= 2.8.0) pero está instalado 2.6.0-3.
    Depende: libfribidi0 (>= 0.19.2) pero está instalado 0.10.9-1.
    Depende: libgsm1 (>= 1.0.13) pero está instalado 1.0.12-1.
    Depende: libjpeg62 (>= 6b1) pero está instalado 6b-14.
    Depende: libmng1 (>= 1.0.10) pero está instalado 1.0.9-1.
    Depende: libncurses5 (>= 5.7+20100313) pero está instalado 5.7+20081213-1.
    Depende: libopencore-amrnb0 que es un paquete virtual.
    Depende: libopencore-amrwb0 que es un paquete virtual.
    Depende: liborc-0.4-0 (>= 1:0.4.6) que es un paquete virtual.
    Depende: librtmp0 (>= 2.3) que es un paquete virtual.
    Depende: libvpx0 (>= 0.9.0) que es un paquete virtual.
    ¡Incapaz de resolver las dependencias! Desistiendo…
    Los siguientes paquetes están ROTOS:
    mencoder
    0 paquetes actualizados, 1 nuevos instalados, 0 para eliminar y 6 sin actualizar.
    Necesito descargar 5372kB de ficheros. Después de desempaquetar se usarán 11,9MB.
    ¿Desea resolver las depedencias manualmente? [N/+/-/_/:/?] n

  • Esta entrada tiene casi dos años y mucho ha llovido desde entonces.. No se como anda ahora el tema y no tengo ninguna Debian para probar mas que un servidor en el que no puedo hacer este tipo de pruebas así que no puedo ayudarte.. Mira a ver que encuentras por Google o pasate por esdebian.org que seguro que allí encuentras información a manta.