Soluciones

Joomla! 4 está al caer…

Aunque aún no ha sido publicada la próxima versión mayor de Joomla y cuyo manifiesto fue publicado en Diciembre de 2016, aprovechando las vacaciones he actualizado mis instalaciones de Joomla! a la última versión disponible a día de hoy (3.8.3) y me he encontrado con un mensaje (en realidad aparece desde la 3.7 pero entonces no le hice mucho caso) que dice:

Al comenzar con Joomla! 4.0 estamos aumentando los requisitos mínimos del servidor. Si está viendo este mensaje, entonces su configuración actual no cumple con estos nuevos requisitos mínimos.

Los requisitos mínimos son los siguientes:

  • PHP 5.5.9
  • MySQL 5.5.3
  • PostgreSQL 9.2
  • MS SQL no se soportará
  • MySQL usando la extensión de PHP ‘ext/mysql’ en modo legado no se soportará, MySQLi o PDO MySQL deberá usarse en su lugar

Póngase en contacto con su proveedor de alojamiento para preguntar cómo puede satisfacer estos requisitos de servidor. Por lo general, es un cambio muy sencillo. Si ya cumple con estos nuevos requisitos, este mensaje no se mostrará.

De momento aunque aún no tenemos fecha definitiva en el Roadmap el pasado 17 de noviembre de 2017 se publicó la versión Alpha 1 y tan solo dos días después la Alpha 2 con algunas correcciones reportadas por la comunidad en el Joomla World Conference la cual tuvo lugar en Roma en esas fechas, y según su repositorio en GitHub el milestone de Joomla! 4 ya está al 98% por lo que no debe quedar mucho para su lanzamiento definitivo…